ثبت نام .: | :. ورود
ثبت دامنه
سرور رایگان
هاست رایگان
021-41807
پارس پک ، اولین ارائه دهنده خدمات رایانش ابری در ایران
ParsPack
پــــارس پــــک با اتکا به فناوری پیشرفته خود، اولین ارائه دهنده خدمات رایانش ابری در ایران می باشد؛ شما می توانید ضمن استفاده از سرور های اختصاصی و ســـرور های مجازی، از اولـین کاربـران ایـرانی خدمات ابری باشید و از مشاوره رایـگان برای دریافت بهترین خدمات استفاده کنید. با ما تماس بگیرید: 41807-021 و 22118705

سرور ایران


بزرگترین ویژگی سرور های ایران در افزایش سرعت نمایش وب سایت تا چند برابر می باشد و این موضوع برای مخاطبین وب سایت شما کاملا محسوس خواهد بود. همچنین برای گیم سرور ها نیز توصیه می شود که حتما از سرور های مستقر در ایران استفاده نمایند. شما می توانید سرور خود را بسته به نیاز بر روی اینترانت ملی و یا اینترنت میزبانی نمائید.
 
All the best people in life seem to like LINUX.
Steve Wozniak

eximبه تازگی آسیب‌پذیری خطرناکی با شناسه CVE-2018-6789 بر روی میل‌سرور ( Mail Server ) اگزیم ( Exim ) به صورت عمومی منتشر شده است.  این آسیب‌پذیری امکان اجرای کدها مخرب از راه دور ( Remote Code Execution ) را برای نفوذ کننده فراهم می‌سازد. اگزیم یکی محبوب‌ترین سرویس های انتقال پیغام ( Message Transfer Agent به اختصار MTA ) در توزیع‌های لینوکس است که با مجوز گنو ( GNU ) ارائه و به صورت همگانی توسعه داده می‌شود که از محبوبیت بسیار زیادی در میان سرویس‌های ایمیل برخوردار می باشد. این باگ در تابع کدگذاری Base64 اگزیم قرار دارد و همه نسخه‌های آن را شامل می‌شود. طی پژوهشی که در این رابطه انجام پذیرفته، این آسیب‌پذیری بیش از 400 هزار سرور را در معرض خطر قرار داده است. خوشبختانه این مشکل در نسخه 4.90.1 که به تازگی منتشر شده است، Patch شده است. بنابراین در صورتیکه از این میل‌سرور استفاده می‌نمایید نیاز است هر چه زودتر نسبت به بروزرسانی آن اقدام نمایید، خوشبختانه سیستم‌عامل‌های مرسوم همگی Patch آن را در آپدیت‌های خود اعمال نموده‌اند و در صورت آپدیت سیستم‌عامل این مشکل مرتفع خواهد شد.

تاریخچه اتفاقات پیرامون این آسیب‌پذیری به صورت زیر می باشد:

  • 5 فوریه 2018: گزارش آسیب‌پذیری به Exim
  • 6 فوریه 2018: دریافت Common Vulnerabilities and Exposures (CVE)
  • 10 فوریه 2018: انتشار Patch

در ادامه به اختصار توضیحی درباره شیوه ارتقای این میل‌سرور در کنترل‌پنل دایرکت‌ادمین ( DirectAdmin ) ارائه می‌شود.

 ارتقای Exim در دایرکت‌ادمین برای پیشگیری از آسیب‌پذیری CVE-2018-6789

 برای ارتقای ورژن Exim لازم است تا  CustomBuild 2.0 بر روی سرور نصب باشد، در صورت نصب بودن CustomBuild 1.x نیاز است ابتدا ارتقای CustomBuild را به ورژن 2.0 را انجام نمایید. برای بررسی ورژن CustomBuild نصب شده بر روی سرور می‌توانید از دستورات زیر استفاده نمایید:

 cd /usr/local/directadmin/custombuild
./build version

 پس از اینکه از نصب بودن CustomBuild 2.0 اطمینان حاصل نمودید می‌توانید با استفاده از دستورات زیر ارتقای Exim را انجام نمایید:

 cd /usr/local/directadmin/custombuild
./build update
./build set exim yes
./build exim

 پس از آپدیت Exim می‌توانید ورژن آن را نیز از طریق دستور زیر بررسی نمایید تا 4.90.1 یا بیشتر باشد:

exim -bV | head -1

 

چند نکته در مورد میل‌سرور Exim

علاوه بر اطلاع‌رسانی‌های که در جهت پیشگیری از مشکلات امنیتی موجود بر روی سرورها انجام می‌پذیرد، گاهی مقالاتی به منظور ارائه آموزش‌های مرتبط جهت استفاده از سرویس‌های گوناگون از جمله سرویس Exim منتشر می‌گردد که با صرف زمان کمی می‌توانید با تنظیمات و عملکرد آنها آشنا شوید. در ادامه می‌توانید برخی از مقالات مرتبط در این زمینه را مطالعه فرمایید:

 آشنایی با نرم افزار ایمیل اگزیم ( Exim ) در لینوکس

آموزش نصب و کانفیگ میل سرور اگزیم exim 4 و اتصال آن به SMTP server خارجی در دبیان و اوبونتو

چگونه وب سایت های آلوده و ارسال کننده هرزنامه ها و اسپم را در سرور شناسایی کنیم؟

 

 

 

کلیه حقوق برای شرکت دانش بنیان پارس پک محفوظ می باشد.
Copyright © 2018 Pars Parva System Ltd. ParsPack Cloud Computing Technology ® , All Rights Reserved.
-->